The BDcraft forum has migrated.
You are currently browsing the Archived BDcraft Forum.
To post a new topic, comment or patch, let's go to the new forum: BDcraft Community Forums


3 replies [Last post]
Sincspeed's picture
Joined: 15/02/2012

I recently ( 15/02/2012 downloaded the texture pack, when i started Minecraft an error occured saying that i didn't have enought space on java or something:

Minecraft had run out of memory, This could be caused by a bug or by the Java Virtual Machine not being allocated enough memory. If you are playing in a web browser, try downloading the game and playing it offline, To prevent level corruption, the current game has quit, Please restart the game.

believe me i restarted it lots of times. + i downloaded it , never played online with this package.

Is anyone able to help? ( didn't do much research i tought this would be the best site/ thing to post or ask something about it ) thx!


stormrider's picture
Joined: 02/01/2012

Due to the higher quality of the textures and thus the bigger size, this may actually happen. At startup a Java application gets a predetermined maximum of memory, this value can be overwritten by command line options.

I assume you are using Windows. If you have link on your Desktop, you might add the options there (see below). It's easier to increase this value globally. Go to Control Panel → Java, select the Java options tab. In the list of parameters add "-Xmx1024m" (without "", not sure, if you have to ommit the - as well) to allow Minecraft to use 1GB of RAM, although 512MB may be enough, just try a few values. The lower, the better, since your system will have more ressources for everything else.

Of course you may use a lower resolution of the pack.

So back to manually setting the value for Minecraft alone:
I don't play Minecraft in Windows, so I have no idea how a link would look. It should work if you set the link target to:

"C:Program FilesJavajre6binjavaw.exe" -Xmx1024m -jar "C:PathToMinecraft.exe"

You may need to adjust the paths depending on you system.

If you still receive the error, add "-Xms1024m" as well (or whatever value you chose), this will increase the memory available at start up.

Sincspeed's picture
Joined: 15/02/2012

I tried to link it in the search bar of my doculents , sadly enough my pc couldn't find it Hmm i did find a ' javaw ' file tough. ( couldn't open it ) . i'm not a big computer expert xP. I do have to put it in the search bar do i ? can you help me out again.

Sphax's picture
I am the AdministratorI released a major BDcraft patchI love galleriesI searched for an answer myselfThe Cake is a lieI explored bdcraft websiteI like to comment everythingI love to post here
Joined: 10/11/2011

Have you checked the FAQ? Read the FAQ Winking