[Game Bug|Bedrock] Big FPS drop especially when dropped items are nearby on RTX cards

Found something odd, buggy, or things missing regarding our resourcepacks or website?
Do not post issues when using mods here.
Post Reply 
User avatar
3 Posts
 x 0

Post 09 Dec 2020, 00:23

Under 1.16.200 there is now a FPS drop which makes the game unplayable if certain dropped items are nearby.

See the video - dropped sugarcane brings me down to under 10FPS, but dropped dirt doesn't drop FPS at all.



I tried changing from 256 res to 64, it made no difference.

This is on a i7 9700k with a RTX 3080. At no time was the system under heavy load though.

There is no lag with default textures.

Note I get a similar issue near big oceans but haven't pinpointed the cause yet.

I will also report this to Mojang.
If you like our work please consider becoming a Supporter and get an ad-free experience.
User avatar
BDcraft Web Admin
6865 Posts
 x 398

Post 09 Dec 2020, 09:02

That's interesting. I didn't notice any dips when I tried, but the latest release did change some rendering things.

I assume this is the bug report to Mojang? https://bugs.mojang.com/browse/MCPE-109965

EDIT: Mojang closed the previously linked report in favour of this one: https://bugs.mojang.com/browse/MCPE-111547
Last edited by HanFox on 06 Mar 2021, 16:08, edited 1 time in total.
Reason: New bug report link
Profile pic by TsaoShin: https://www.deviantart.com/tsaoshin
User avatar
3 Posts
 x 0

Post 10 Dec 2020, 07:33

Yes that's my report on Mojang.

I've had this tried on other PCs with the same texture pack - i7 8086k / GTX 970, and a i7 4790k / GTX 980. Neither of them have this issue.

I've tried uninstalling MC and installing the latest video card drivers, and running my desktop at 1080p instead of 4k. None of this has helped.

The only thing I have left to try is swapping my RTX 3080 out for a non RTX card. I'm not running it in RTX mode but maybe the game is doing something weird when it detects a ray tracing card.
User avatar
2 Posts
 x 0

Post 11 Dec 2020, 02:33

I am playing Bedrock on Windows 10, RTX 3080 and i9-9900k. Ever since the latest update, PureBDCraft mod is unusable for me. The game is either extremely laggy, crashes, or works and then quickly slows down to becoming unplayable. Was working fine, until the last patch. Has anyone experienced this?
User avatar
1 Post
 x 0

Post 13 Dec 2020, 00:11

vcast wrote:
11 Dec 2020, 02:33
I am playing Bedrock on Windows 10, RTX 3080 and i9-9900k. Ever since the latest update, PureBDCraft mod is unusable for me. The game is either extremely laggy, crashes, or works and then quickly slows down to becoming unplayable. Was working fine, until the last patch. Has anyone experienced this?
Yes, it's effecting me as well. Running PureBDCraft Vanilla on a Intel I9-9900KF @5.0GHz on all cores, RTX 2080TI, 64GB DDR4 3600, 970 EVO+ SSDs. CPU and GPU loads are minimal at best when running this texture pack. however frame rate drops to single digits anywhere near my chicken farm, and about 50fps in general since these patches. If I switch to default Minecraft texture pack and load back in to the same exact position of the same world: my framerate maxes out at 165FPS (G-Sync is on and 165hz is my monitors max refresh rate)

I should also mention that this lag issue started with the 1.16.100 patch. Now we're in 1.16.200.2 and it's still bad. Single digit framerates are painful.
BDCraft Vanilla HD shown
Image

Default texture pack shown

Image
User avatar
1 Post
 x 0

Post 22 Jan 2021, 00:07

I am experiencing incredibly low fps on both a single player and realm server. Both on bedrock edition. I have changed the resolution of the texture pack many times. Yh fps gets even worse around mobs and dropped items. When I swap to normal textures everything is immediately fine. I really want to use the texture pack but it is unplayable.
User avatar
BDcraft Web Admin
6865 Posts
 x 398

Post 22 Jan 2021, 12:51

OrangeRules wrote:
22 Jan 2021, 00:07
I am experiencing incredibly low fps on both a single player and realm server. Both on bedrock edition. I have changed the resolution of the texture pack many times. Yh fps gets even worse around mobs and dropped items. When I swap to normal textures everything is immediately fine. I really want to use the texture pack but it is unplayable.
I merged your post here, as this is the general "I suddenly lag" thread -- it isn't strictly just about dropped items any more.

We are unaware of a fix currently. Not everyone seems to suffer poor FPS.

Maybe try posting a new bug report on https://bugs.mojang.com
Profile pic by TsaoShin: https://www.deviantart.com/tsaoshin
User avatar
1 Post
 x 0

Post 16 Feb 2021, 12:39

Has this been fixed or at least why it has happen.
User avatar
1 Post
 x 0

Post 27 Feb 2021, 15:50

Any update on this? This pack makes me have extremely low FPS while on my world, no matter the resolution of the pack.
User avatar
1 Post
 x 0

Post 03 Mar 2021, 22:34

Playing on a I7, 9th gen and 2060 RTX, I get the same lag spike also, regardless of what resolution I use, the only fix I've found is switching to the default texture pack,

I was reluctant to change but I was trying to clear a forest and was dropping down to less than 12fps. That being said, I'm inclined to believe its something to do with dropped saplings, or other crops as I would get a noticeable (albeit more manageable) framedrop whenever I was clearing my wheat farm.

Anyway, somethings definitely wrong and only seems to be affecting this texture pack
Post Reply