[Aesthetics|Customiser] Sandy Clay doesn't match normal sand colours when using OptiFine

Found something odd, buggy, or things missing regarding our resourcepacks or website?
Do not post issues when using mods here.
Post Reply 
User avatar
Lifetime Supporter
3 Posts
 x 1

Post 28 Aug 2021, 06:39

(sorry for the bad formatting if I do it wrong... or whatever, never written one of these for a bug I found.?)

The Customizer has a Clay Block replacement, from the usual grey block to the clay blobs in sand.

However the Sand block around the clay doesn't blend into other Sand Blocks... or Optifine Connected Textures.

Do not take my word for this completely... (Run a world with Optifine CT,Sphax,Customizer and look for yourself for proof. place the clay in just a sand pit in water.) most of the time though it doesn't blend into the other sand blocks around it and pops out more then it should.

Making it quite um well weird looking, (Like it suppose to blend into the sand right? but the texture is like a different color? or something? I'm not sure how to describe this better?)
User avatar
BDcraft Web Admin
6910 Posts
 x 407

Post 28 Aug 2021, 07:52

This is due to the Custom Colours in OptiFine and the clay not being defined in them.

In the Customiser for me to fix it it'd require adding in the ability to modify and package an extra file for it to work.

For you now, there's two options:
1) Disable Custom Colours in OptiFine's settings.
2) Open the PureBDcraft pack navigate to /assets/minecraft/optifine/ and open color.properties and on the end of the palette.block.~/colormap/sand.png line add clay
Profile pic by TsaoShin: https://www.deviantart.com/tsaoshin
Post Reply