[64x/32x] Enigmatica 2 [MC1.12]

Tekkit? Feed the Beast? All texture compilations (WIP and full releases) for mod packs go in here.
Post Reply
User avatar
2 Posts
 x 0

Post 16 Feb 2020, 21:10

Reloading fixed it!

Thanks for the extremely fast response!
If you like our work please consider becoming a Supporter and get an ad-free experience.
User avatar
1 Post
 x 0

Post 29 Sep 2020, 01:10

Hey!

Here's a couple fun notes from my afternoon of debugging. Figured I'd share them, in case you may find them interesting.

Enigmatica 2 Expert Skyblock.

Try as I may, I could not get this patch to load with Optifine. Yeah, I know, Optifine evil. Tried both 64x and 32x. Also tried loading only this patch, no other packs, not even PureBD base. Worth mentioning that if I remove Optifine, it all works perfectly fine.

It would complain about some OpenBlocks texture, which is apparently a known issue: https://github.com/sp614x/optifine/issues/787 -- I get pretty much the exact stack trace as the last guy in that thread.

Now here's the odd things:

- If I switch resource packs from within the game (as in, in a world, not just the menu), it will load fine. But some textures will be funky due to the unclean atlas. Restarting the game like this will crash.
- I've tried with some other resource packs I had on hand and optifine and they don't cause the same issue: Faithful32 (+modded) Soartex Fanver Universal and Unity (+modded).

Normally, logic would dictate that there's something wrong with the OpenBlocks textures of this patch, however I don't know how a texture would possibly cause such a crash. This has got me stumped. I might try removing single textures from the OB namespace; who knows, maybe there's a single culprit somehow? I'm not expecting anything. As I said, I don't know how a texture could possibly be at fault.

It doesn't seem to be running out of memory either. VRAM usage never goes over 30% while loading, and I gave minecraft 64Gb of RAM in a fit of "screw it, give it moar" and it never even approached allocating 20Gb while loading.
Last edited by mkaito on 29 Sep 2020, 01:33, edited 3 times in total.
User avatar
13 Posts
 x 0

Post 03 Nov 2020, 00:24

I started a server of Enigmatica 2 Expert and now that i am at Ender Energy conduits i notice when i place them down they are invisible until i walk a chunk away and come back then you can see them. This is only happening on the server. When i try in singleplayer and i cheat in the conduits i can place them fine they show up like they should. I am not sure what could be causing this issue happens on all 3 of our computers that are playing on the server.
User avatar
Patch Creator
1454 Posts
 x 121

Post 03 Nov 2020, 08:04

As it is part of the Thermal Suite, I would say disable mipmaps. Also if you are using it, remove Optifine. Apart from that no idea. Try asking HanFox on the Thermal Dynamics thread.
If anyone would like to take over any of my threads please contact me. I will continue to host what I have done but expect no further updates.
Post Reply