[128x/64x/32x] Feed the Beast: Infinity [MC1.7/1.10.2]

Tekkit? Feed the Beast? All texture compilations (WIP and full releases) for mod packs go in here.
Post Reply
User avatar
Patch Contributor
124 Posts
 x 0

Post 24 Feb 2015, 05:50

Balekin wrote:Here's my log report. It was too long to put into spoiler tags so here's the pastebin link: http://pastebin.com/gLKHp6g3
Silentkills22 wrote:I am having the same problem. I am trying to use the x128 packs. I download the patch and the resource pack put them in the correct folder and set the both to be active. After a few seconds of loading it goes back to the options screen with vanilla textures. When I go back into resource packs both are put back on the left side. Also I tried this without the patch active and the pack loaded up fine. I don't know if that will mean anything to you.
Seeems that you have not enough RAM set, ty to increase it.
Show

Code: Select all

[20:41:41] [Client thread/INFO]: Caught error stitching, removing all assigned resourcepacks
net.minecraft.util.ReportedException: Registering texture
        at net.minecraft.client.renderer.texture.TextureManager.func_110579_a(SourceFile:91) ~[bqf.class:?]
        at net.minecraft.client.renderer.texture.TextureManager.func_110549_a(SourceFile:136) ~[bqf.class:?]
        at net.minecraft.client.resources.SimpleReloadableResourceManager.func_110544_b(SourceFile:104) ~[brg.class:?]
        at net.minecraft.client.resources.SimpleReloadableResourceManager.func_110541_a(SourceFile:92) ~[brg.class:?]
        at net.minecraft.client.Minecraft.func_110436_a(Minecraft.java:598) [bao.class:?]
        at net.minecraft.client.gui.GuiScreenResourcePacks.func_146284_a(SourceFile:151) [bgf.class:?]
        at net.minecraft.client.gui.GuiScreen.func_73864_a(GuiScreen.java:225) [bdw.class:?]
        at net.minecraft.client.gui.GuiScreenResourcePacks.func_73864_a(SourceFile:158) [bgf.class:?]
        at net.minecraft.client.gui.GuiScreen.func_146274_d(GuiScreen.java:296) [bdw.class:?]
        at net.minecraft.client.gui.GuiScreen.func_146269_k(GuiScreen.java:268) [bdw.class:?]
        at net.minecraft.client.Minecraft.func_71407_l(Minecraft.java:1628) [bao.class:?]
        at net.minecraft.client.Minecraft.func_71411_J(Minecraft.java:961) [bao.class:?]
        at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:887) [bao.class:?]
        at net.minecraft.client.main.Main.main(SourceFile:148) [Main.class:?]
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_31]
        at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_31]
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_31]
        at java.lang.reflect.Method.invoke(Unknown Source) ~[?:1.8.0_31]
        at net.minecraft.launchwrapper.Launch.launch(Launch.java:135) [launchwrapper-1.11.jar:?]
        at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.11.jar:?]
Caused by: java.lang.RuntimeException: Can't fit all textures, use lower resolution texture packs or remove mods.
        at fastcraft.a.h.a(F:305) ~[fastcraft-1.19.jar:?]
        at fastcraft.a.h.a(F:259) ~[fastcraft-1.19.jar:?]
        at fastcraft.a.h.a(F:48) ~[fastcraft-1.19.jar:?]
        at fastcraft.a.h.a(F:68) ~[fastcraft-1.19.jar:?]
        at fastcraft.a.i.a(F:147) ~[fastcraft-1.19.jar:?]
        at fastcraft.Hooks.g(F:74) ~[fastcraft-1.19.jar:?]
        at net.minecraft.client.renderer.texture.TextureMap.func_110571_b(TextureMap.java:242) ~[bpz.class:?]
        at net.minecraft.client.renderer.texture.TextureMap.func_110551_a(TextureMap.java:90) ~[bpz.class:?]
        at net.minecraft.client.renderer.texture.TextureManager.func_110579_a(SourceFile:72) ~[bqf.class:?]
        ... 19 more
Image
User avatar
2 Posts
 x 0

Post 24 Feb 2015, 13:35

It worked ok with infinity 1.0.0 but 1.2.0 doesn't. I'm set on 16gb ram max on launcher.
User avatar
17 Posts
 x 0

Post 25 Feb 2015, 00:41

How much ram does this resource pack need? I've tried going up to 7G and it still doesn't work. It used to work well enough before Infinity did it's latest update. But now suddenly it's become a massive memory hog? Is there a problem with the modpack itself?
User avatar
2 Posts
 x 0

Post 25 Feb 2015, 02:39

Yeah I use 5 gigs of ram.... And I just bumped it up to 10 and it still doesn't work. I don't think its a ram issue.
User avatar
Supporter
14 Posts
 x 0

Post 25 Feb 2015, 08:43

So does this still work?
trying to run the 128x on FTB infinity 1.1.0 server and the client gets to mojang everything looking fine in console but after about 4-5 minutes hanging on the Mojang screen the console reports: Registering texture several times and just doesn't do anything further..
Client opens fine without the texturepack, have already fiddled with RAM settings trying every 1gb incrament from 3gb - 10gb of RAM and still nothing...
Ideas? My eyes are getting cancer from using the default textures.. :o
cheers
User avatar
Former Staff
1132 Posts
 x 0

Post 25 Feb 2015, 11:22

If any of those of you having issues could provide crash reports, we could help you out a lot better. 90% of all issues with HD texture patches are issues with RAM, not the textures themselves. A crash report would identify this immediately.

I've read a few of the logs that have been posted and those do indicate a RAM issue. When the textures can't be stitched together in memory, they will default to vanilla textures. Try using 64x resolution and if that solves your problem, then you know for sure it's a RAM issue. The general rule is to keep lowering the resolution until it works. Anyone having issues with 128x, should use 64x and anyone having issues with 64x, should use 32x respectively.

Edit
Please try a lower resolution before spamming the forum with "why won't this just work, it worked before" or "It can't be a RAM problem".
User avatar
Patch Contributor
124 Posts
 x 0

Post 25 Feb 2015, 12:45

So I tried to reproduce it with version 1.2 and the 64x version and it just loads fine for me how you can see here:
http://i.imgur.com/xsydZsj.png
Unfortunately I can't test the 128x version as I have not enough RAM for it.
Image
User avatar
Supporter
14 Posts
 x 0

Post 25 Feb 2015, 13:23

As mentioned in someones reply, I have downgraded to the 64x pack which I can confirm works fine!
was just surprised that when using the 128x pack with 10gb of my 16gb of RAM allocated to it that it wouldn't work so apology for jumping to conclusions that it was broken. How much RAM is actually needed to run the 128x?
Cheers
User avatar
17 Posts
 x 0

Post 26 Feb 2015, 00:40

SirWill wrote:So I tried to reproduce it with version 1.2 and the 64x version and it just loads fine for me how you can see here:
http://i.imgur.com/xsydZsj.png
Unfortunately I can't test the 128x version as I have not enough RAM for it.
How much ram are you assigning to Minecraft to get the 64x version to work? Like I said above, I was giving it up to 7G and it still wasn't working.
User avatar
Former Staff
1132 Posts
 x 0

Post 26 Feb 2015, 00:56

Daxtillion wrote:As mentioned in someones reply, I have downgraded to the 64x pack which I can confirm works fine!
was just surprised that when using the 128x pack with 10gb of my 16gb of RAM allocated to it that it wouldn't work so apology for jumping to conclusions that it was broken. How much RAM is actually needed to run the 128x?
Cheers
Sadly each system is different. You have to not only take into consideration the speed/size of your system RAM but also the RAM on your video card. There are no reliable specifications for running Minecraft with HD textures, it's all trial and error. With each new iteration 1.6, 1.7, 1.8, etc... it becomes more and more taxing on your systems resources as for some reason Minecraft is persistently unoptimized graphic-performance-wise.

@Balekin What model graphics card do you have?
Post Reply