BDCraft 512x Works Really Slow

Technical assistance with our resourcepacks, website, or general help with Minecraft - including mods.
Post Reply
User avatar
5 Posts
 x 0

Post 28 Jan 2019, 18:43

Now I'm not sure if that should be this slow with my computer. My specs are:

i5 - 7400 CPU 3GHz
16 GB Ram
GTX 1060 6 GB (gaming model)

I first thought that it need a little bit more RAM, so I went to advance options and gave it 4 GB instead of 2. That didn't work. Right not it has 8 GB of RAM and still works really slow. My GUP is up to date. Any help will be appreciated.
User avatar
BDcraft Web Admin
5715 Posts
 x 195

Post 28 Jan 2019, 19:05

Are you sure you're using your Nvidia GPU and not the integrated Intel one?
If you like a post give it a diamond! :arrow_heading_up:
User avatar
5 Posts
 x 0

Post 28 Jan 2019, 19:16

When I press F3 in game it shows my GPU as Nvidia GeForce 1060. So if that's it yes I'm sure.
User avatar
BDcraft Web Admin
5715 Posts
 x 195

Post 29 Jan 2019, 07:24

You're likely down to just general troubleshooting then like making sure Java is up-to-date, making sure your graphics drivers are up-to-date, trying to reinstall Minecraft.
If you like a post give it a diamond! :arrow_heading_up:
User avatar
5 Posts
 x 0

Post 30 Jan 2019, 22:24

https://imgur.com/a/VYpNDRp
Sorry couldn't take the screen shot without the menu. Maybe you can see the problem. I installed it again, Java is up to date, no problems with GPU... So I did everything you told to me and nothing works. Any idea?
User avatar
Supporter
17 Posts
 x 5

Post 31 Jan 2019, 07:20

I would recommend installing Optifine. Java Minecraft just isn't optimized very well, even on decent rigs. I hope that changes in future updates. In the meantime, Optifine really helps smooth things out and you should get a better FPS with it. I can advise you on some settings that work well for me, if you'd like.
I'm wicked, so what?
User avatar
5 Posts
 x 0

Post 31 Jan 2019, 07:43

enderkitsune wrote:
31 Jan 2019, 07:20
I would recommend installing Optifine. Java Minecraft just isn't optimized very well, even on decent rigs. I hope that changes in future updates. In the meantime, Optifine really helps smooth things out and you should get a better FPS with it. I can advise you on some settings that work well for me, if you'd like.
Yes, that would be great since I've never used it before.
User avatar
Supporter
17 Posts
 x 5

Post 31 Jan 2019, 08:40 

In the Performance settings, try setting these to On: Smooth FPS, Fast Render, Smart Animations, Smooth World, and Lazy Chunk Loading. You can also try Render Regions if you have VBOs turned on.

Another thing you could do is change the Java runtime Minecraft uses to the one installed on your computer, rather than the one that comes bundled with Minecraft. In the launcher, go to Launch options and select Optifine, then enable the Java executable option. Open the little folder to the right, and paste this in the navgation bar: C:\Program Files\Java\

You should see some folders beginning with jre1.8.0_ and ending with numbers. Open the folder that ends with the highest number (it should be 201, the latest release), then open bin, and look for javaw.exe, or just javaw if you hide file extensions.

Finally, you can try also enabling the JVM arguments. These settings can help improve and smooth out performance. If you do, be sure to paste this at the beginning -Xmx8G, before the -XX:+UseG1GC to have Minecraft use up to 8 GB of RAM.

I hope these help!

I've tried all these myself with the 512x (I normally use 128x) and I've found that when I've just loaded into the world, or changed the texture pack, the FPS is abysmal for a minute or two. But after a minute or so has elapsed, the FPS will greatly improve. So try waiting a minute without moving and see if that helps.

And also it still only uses like 12% of my GPU, lol.
I'm wicked, so what?
User avatar
5 Posts
 x 0

Post 31 Jan 2019, 11:00

Thank you very much kind stranger. That really did solve my problem. Thank you again :)
Post Reply