[HELP] JSON Does Not Change Block Model

Archives of technical help for Cubik LITE and Cubik PRO

Now help is given on Cubik Studio forum: https://cubik.studio
Locked
User avatar
2 Posts
 x 0

Post 23 Mar 2014, 21:51

I am struggling with getting the JSON file I create to work in my resource pack. I am placing the file in the minecraft/models/blocks/meshes folder and naming the files correctly (at least I think) but it will not take affect. I would appreciate learning how to fix this. I have only attempted to create these for rails and ladders so far, not any basic blocks.
User avatar
BDcraft Admin
2180 Posts
 x 13

Post 24 Mar 2014, 06:31

You should start with basic block to understand forstly how Minecraft work.

But it's pretty simple.

The json files in the models folder are the files that describe each block by referencing which mesh will be used.
If you change a mesh, be sure to edit the json which describes the block to set the mesh to use. ;)
If you like a post give it a diamond! :arrow_heading_up:
Have you tried Cubik?
User avatar
15 Posts
 x 0

Post 24 Mar 2014, 16:45 

If you are still not exactly sure what you have to do, I posted a little instruction for that: http://bdcraft.net/community/cubik/how- ... tml#p12031
User avatar
2 Posts
 x 0

Post 24 Mar 2014, 21:47

Thanks, I suppose I should've started with a basic kinda block anyway. If I have any more issues I'll update.

-- 24 Mar 2014, 16:47 --

I was doing this completely correct except for the simple error of naming the file "blocks" instead of "block". Everything is working properly now!
User avatar
BDcraft Admin
2180 Posts
 x 13

Post 24 Mar 2014, 22:17

Glad to see everything is now solved :)
If you like a post give it a diamond! :arrow_heading_up:
Have you tried Cubik?
Locked