Having an issue with BDCraft Animaker and BDCraft Cubic.

Archives of support and help for Animaker

Now support is done on Cubik Studio forum: https://cubik.studio
Post Reply
User avatar
2 Posts
 x 0

Post 27 Dec 2015, 15:59

Hello to everyone.

I'll go straight to the problem that I have.

1) I make 512x512 .png format texture such as this one
Show
Image


2) I save it as "laser_all.png" and place it in "Animakers" lib folder

3) Open it in "Animaker", make it animate, by rendering 32 frames and save is as a spritesheet.

4) "Animaker" saves the spritesheet and names it "xxxx_32.png", this image I renamed to "saber_light.png".

5) Create "saber_light.png.mcmeta" file and write the "code" : (Code goes below)

Show

Code: Select all

{
	animation {
		frames [
			0,
			1,
			2,
			3,
			4,
			5,
			6,
			7,
			8,
			9,
			10,
			11,
			12,
			13,
			14,
			15,
			16,
			17,
			18,
			19,
			20,
			21,
			22,
			23,
			24,
			25,
			26,
			27,
			28,
			29,
			30,
			31
		]
	}
}


6) Save the "code" file.

So far everything seems to be great..

7) Now I open "BDCraft Cubic" model an object that should later be used in game as a weapon (sword)

8) Adding texture!

When I try to import the texture/s that I made with "Animaker" into "Cubic" they never load. (How I am importing textures : open "Tools" dropdown menu, in that menu select "Material Manager". When "Material Manager" opens I double-click "texture" file, then pick a texture that I made and want to use, but when I select the texture that I want and clicl "Open" button to sellect a texture the window in which I selected texture disapears as it should, but no texture appears in "Cubic Material Manager". I have tried placing textures in extracted resource pack folders, in "Animaker" "anim" folder, bunch of random folders it doesn't load no matter what. PLEASE HELP.

-- edit --

This is what I am talking about the issue in it's natural habitat :
Image