Suddenly unable to use 128x packs

You need some technical assistance with our resourcepacks or website or general help with Minecraft, including mods.
Post Reply
User avatar
4 Posts
 x 0

Post 08 Jun 2019, 04:54

For the past couple of days, I've been playing on a small server while using OptiFine and the latest edition of PureBDCraft 128x, as well as a couple of addons. I haven't had any issues at all playing with this setup until today. I tried loading the launcher and got various crash reports any time I loaded the game, all of which recommended that I use a lower resolution pack. And sure enough, 64x Vanilla BDCraft, and any other low res pack I tried, ran just fine.

I tried loading other combinations of packs and addons, and the only ones that caused crashes were PureBDCraft 128x and Vanilla BDCraft 128x. All other packs and addons loaded just fine on their own. When I loaded Minecraft today, I was using the same OptiFine build I used yesterday, 1.14 pre7. I tried updating to pre9 to see if that would help, but nothing changed. I also tried just loading vanilla Minecraft 1.14.2, but it still crashed.

This crash always happens when the game is trying to load textures from a 128x pack. But what's weird is, the crash is never caused by the same texture. I guess it just stops on whichever texture it gets to first. The crashes make it impossible to open the game unless I move the pack I tried to load into a different folder.

Does anyone know why this issue popped up so suddenly? If it had happened sooner, I would assume my computer just isn't strong enough to run 128x packs. But clearly that's not the case since I've used them before with no issues. What might be causing it to happen now?

Here's a couple of crash reports if that's any help.
One while using OptiFine
https://docs.google.com/document/d/1luc ... sp=sharing
And one while using Vanilla
https://docs.google.com/document/d/1VA0 ... sp=sharing

A couple times, OptiFine crashed while loading CTM textures, but for some reason that's not what caused it on this crash report.
User avatar
BDcraft Web Admin
5410 Posts
 x 126

Post 08 Jun 2019, 10:09

An "unable to fit" error is usually due your graphics card not being able to handle the size of the stitched textures.

Basically a card has a max texture width/height. Judging by specs, you should be able meant to handle a max size textureatlas size of 16384x16384... meaning you should have no trouble (you should technically be able to run 512x - video memory allowing). It's odd that it halts on the skeleton though.

As an AMD HD 7700 is a pretty odd card first I'll ask, is that your main card? I know people sometimes run multi GPUs (even old ones) for certain things, so possibly your computer is using the wrong card for Minecraft. It could also somehow be using the Intel integrated graphics instead (although the log doesn't suggest that).

Besides checking the card being used I can only suggest you make sure you have the latest graphics drivers installed. Maybe even try reinstalling Minecraft cleanly.
If you like a post give it a diamond! :arrow_heading_up:
User avatar
4 Posts
 x 0

Post 08 Jun 2019, 17:38

The AMD is my main and only graphics card. I've never been able to run any pack above 128x when I've tried using them in the past. I just updated my GPU drivers and restarted my computer. When I tried switching to the 128x pack again, this is the crash report I got. This one's different than all the other ones I've gotten for some reason. It doesn't specifically say that the problem occurred while loading a texture. https://docs.google.com/document/d/1uHM ... sp=sharing

But then I tried loading the game again without removing changing anything, and the game loaded just fine with the 128x pack already selected. So from there, I tried adding some addon packs to see if those would work, and I got a similar crash report. https://docs.google.com/document/d/1Bx9 ... sp=sharing

Then I tried loading up the game again after the crash, no changes made, and it was working again with all the packs that I'd just tried to load. I was even able to get onto a server with no issues.

So I suppose the problem is kind of solved now, but not entirely? I still don't know what's making my game act up and why it only works under specific conditions. But as long as I don't touch anything, it's working for now. I'll let you know if anything changes.

Edit: Forgot to mention that every time I've tried loading it today, it was with OptiFine 1.14.2 pre9.
Post Reply