[Game Bug|Bedrock] Interacting with a Loom using BDCraft Vanilla crashes the game...

If you've found something odd, buggy or missing regarding our resourcepacks or website. Please describe the issue in detail.
Post Reply
User avatar
6 Posts
 x 0

Post 21 May 2020, 02:48

As per the subject line - just before the game crashes the fps drops to <5fps then boom! The bug tracker for Bedrock Edition has users also saying this affects Pure BDCraft too...

https://bugs.mojang.com/browse/MCPE-69848
User avatar
BDcraft Web Admin
6045 Posts
 x 260

Post 21 May 2020, 07:14

This is quite possibly because they changed how the banner textures are laid out in the beta.

We'll take a look. Thanks for the report.
If you like a post give it a diamond! :arrow_heading_up:
User avatar
BDcraft Web Admin
6045 Posts
 x 260

Post 21 May 2020, 14:42

So I've checked this and had no issues on Windows 10.

I don't know if you've updated MC recently (it got a patch yesterday to 1.16.0.63) which states cryptically:
Fixed several crashes that could occur during gameplay
I know you probably just recently tried, and crashed, but are you sure your client is up-to-date?

Also, are you on the normal beta or the RTX beta?
If you like a post give it a diamond! :arrow_heading_up:
User avatar
6 Posts
 x 0

Post 22 May 2020, 14:00

Thanks for the quick reply.
I'm on 1.16.0.63 the latest version as of this message (not RTX)

So in my main world, using BDCraft Vanilla (I deactivated shaders and all other add ons) and interacting with loom crashes game in 5 or so seconds after fps drops to 5fps or so. I tried the Pure BDCraft pack and the frame rate dropped to 10fps or so but stabilised and didn't crash.

To make sure I wasn't in a glitched world (as there are some nasty bugs in the betas) I created a brand new flat world and interacted with the loom with both your packs and the game crashed within a few seconds of using each. I could capture it in video if that would help.

BTW I absolutely love your packs and wouldn't play MC without using them. Tied with ESBE Shaders the game at 60fps is gorgeous!!
User avatar
6 Posts
 x 0

Post 02 Jun 2020, 03:44

Update for you:
Now using Beta 1.16.0.64 and still the same issue across both packs. Tried not using the separate UI's but makes no difference, the game still crashes. Can I do anything my end ?
User avatar
BDcraft Web Admin
6045 Posts
 x 260

Post 02 Jun 2020, 08:22

Nothing you can do, no. I can only assume the crash is due to the fact the game isn't rendering HD banners correctly in the Loom UI. I've been unable to replicate it.

It's up to Mojang to fix. We reported it via the Partner program. Hopefully it'll be fixed before 1.16 releases fully, or we'll probably get lots of complaints (or it'll fail QA due to crashing from a game bug...).
If you like a post give it a diamond! :arrow_heading_up:
User avatar
6 Posts
 x 0

Post 03 Jun 2020, 09:29

Ok thanks for the heads up - 1.16 full release isn't far away so lets see what happens :-)
Post Reply