[Game Bug|Bedrock] Big FPS drop especially when dropped items are nearby on RTX cards

Found something odd, buggy, or things missing regarding our resourcepacks or website?
Do not post issues when using mods here.
Post Reply 
User avatar
5 Posts
 x 0

Post 17 Jan 2022, 23:27

crisis52 wrote:
03 Dec 2021, 02:19
FIXED!!!!
At least for the Windows 10 edition that I am playing (From the Windows Store)*** The problem is that the game executable that shows up in Nvidia Control Panel is NOT the executable that the game runs when you launch it, so custom settings are NEVER applied to your game.

The first step is finding the actual .exe the game uses to run off of on your computer
1. Start the game, and then open task manager
2. Find the currently running minecraft exe, right click and select open containing folder
3. find the minecraft executable inside this folder (should be Minecraft.Windows.exe) and copy its file path location
4. Open nvidia control panel and click Add under program settings tab
5. Click browse, and then paste the file path you copied into the top input field
6. Select the Minecraft.Windows.exe that shows up in this folder

Now you can get on with editing the settings for the ACTUAL executable that cause the FPS drop. I noticed that minecraft was NOT using my 3080 to actually do 3d rendering for the game, which tells me that the game is bottlenecking the CPU for some stupid reason. In order to offload to the GPU, I changed the following settings;
1. Cuda GPUs - All
2. ***Low Latency Mode - Ultra (This prevents frame queing on the CPU, which allows the GPU to process them faster)
3. OpenGL Rendering GPU - Select your actual graphics card
4. Power Management Mode - Prefer max performance
5. Preferred Refresh rate - highest available
6. Virtual Reality pre-rendered frames - 1

I went from 5-15 fps inside my house, to over 240 fps instantly. Zero lag spikes, and zero fps drops. Cheers, and I hope this works for you.
OMG!! This fixed it for me!! Thank you so much!! I think the most important setting there is the Low Latency Mode - Ultra.
Thanks again!!!

Edit: on the next day, the low fps is back again... oh well... :(

Edit2: after a more in-depth analysis, seems like anything above 64x texture resolution will drop fps greatly in some areas with lots of entities, but the fix solves the problem for 64x and 32x. Solved for me and a friend of mine, at least.
If you like our work please consider becoming a Supporter and get an ad-free experience.
User avatar
1 Post
 x 0

Post 22 Feb 2022, 04:25

Hi All,

I'm using Windows 10 with AMD 3900X and RTX3080 and having the same issues described on this chain. Not sure if there's anything to help resolve, but can add that I play with my kids on our Realm and their iPads using PureBD texture has no issues with lag at all. I was pretty frustrated with Minecraft that I'd have performance issues on my gaming PC with no issues on iOS, but seems this is specific to this texture pack.

Unfortunately, I've grown accustomed to using this skin and can't bring myself to play using a lower res texture pack. Very much love your work, just wish the FPS lag issue can get resolved.

Thanks!

-J
User avatar
1 Post
 x 0

Post 12 Apr 2022, 02:56



I've tried to find the source because it only happens when looking at a certain area in my house, but there was nothing there

I made a new one to test if it still had fps issues and it was completely fine

EDIT: Been doing some more testing, it seems whenever items are rendered on the floor, on armour stands or on item frames, the fps suffers. So for now I'll be using vanilla until this is eventually fixed. I used to use this back on PS5 and I never had major fps issues there when rendering a ton of item frames
User avatar
1 Post
 x 0

Post 22 May 2022, 17:58

Hey,

I have the same Problem :(. Im using Windows 11.
RTX 3070
I7 10700f
32 GB RAM
The FPS going to 5-20 when a few Items are dropped. I dont know what to do, i Just want to Play Minecraft with this pretty Texture Pack. Sometimes the FPS going to 5-20 for no reason.
User avatar
8 Posts
 x 0

Post 08 Jul 2022, 15:36

Im having this same issue, has anyone found a solution yet?
User avatar
1 Post
 x 0

Post 17 Aug 2022, 17:36

I tried doing the aforementioned "windowsapp" trick. I got stuck at not being able to grant myself controls despite following the Windows answer. https://answers.microsoft.com/en-us/win ... 51fe5a4ca9

Looking at that guide a little more, I happened into my GeForce app and was looking at Minecraft. One thing that I noted was that Raytracing was on (even though I wasn't using it). I guess by default Minecraft or Nvidia turns it on because it detects the card.

I went to the \com.mojang\minecraftpe folder and opened the options.txt and turned gfx_raytracing:1 to gfx_raytracing:0.

This made it so I went from 240 fps to 40 fps instead of 240 fps to 15 fps.

Not perfect but much more manageable.

Note: I also have gfx_vsync:0 instead of gfx_vsync:1.
Note2: Currently using 64 resolution. Haven't tried others yet.
Post Reply