Incompatible w/ ComputerCraft 1.56 (dot & spacing bug)

You need some technical assistance with our resourcepacks or website or general help with Minecraft, including mods.
Locked
User avatar
5 Posts
 x 0

Post 14 Aug 2013, 21:02

Image
TexturePacks : Sphax PureBDcraft 128x MC16
MC : 1.6.2
Forge : 9.10.0.804
ComputerCraft : 1.5.6
Optifine : was not the cause, disabling them still produce the same bug.

Pure BD was also suffer from weird spacing, although it cope much better than other ResourcePack.

Dotted screen only happen in PureBD, other HD ResourcePack (example:Flow's) was fine, but suffer much worse mess up spacing.
Image
User avatar
BDcraft Web Admin
5467 Posts
 x 129

Post 14 Aug 2013, 21:12

*moved to Help*

I'd be more inclined to say CC is incompatible with HD fonts.

In all fairness CC is trying to space the text out as if it were all of equal width (like a normal terminal using a font such as System or similar). Really CC should have it's own font file in order to stop HD fonts going weird due to their non-conventional spacing.

I would be inclined to bring it up on the CC forum and see what they think there, because it's not the texturepacks fault the mod renders it oddly.
If you like a post give it a diamond! :arrow_heading_up:
User avatar
5 Posts
 x 0

Post 14 Aug 2013, 21:44

actually I found some workaround to the spacing problem, but that step is really tedious.
Moderator at cc forum said that it's highly unlikely they will add support for hd font :(
you can check that statement on their forum, under bugs section, similar post on same issue.
Last edited by Agnessan on 14 Aug 2013, 21:47, edited 1 time in total.
User avatar
BDcraft Web Admin
5467 Posts
 x 129

Post 14 Aug 2013, 21:47

Well suggest to them that if they won't support HD fonts that they should force use of the default font.

That way the issue goes away.
If you like a post give it a diamond! :arrow_heading_up:
User avatar
5 Posts
 x 0

Post 15 Aug 2013, 07:38

The spacing "bugs" is not that annoying (in PureBD).
I often wrote code in external app, or in pastebin. rarely use the CC "computer", only use them to wrote a small one-time-use script.
Plus there are also a workaround to get rid (decreasing) the weird spacing.

But on PureBD, the real problem was the dotted screen, and that is really hurting my eyes :(

-- 15 Aug 2013, 07:38 --

So, how do I fix this dot screen bug, because it's only happen in this PureBD
User avatar
BDcraft Web Admin
5467 Posts
 x 129

Post 15 Aug 2013, 17:27

I would suggest you look at other fonts that work correctly and compare them to the PureBD one.

See if the PureBD one has odd spacing around the dot that others do not.

I still suggest you push the CC mod authors to see if they can just force the use of the default Minecraft font though...
If you like a post give it a diamond! :arrow_heading_up:
User avatar
Patch Creator
52 Posts
 x 0

Post 15 Aug 2013, 18:03

Erase the dot above the 0 on ascii.png
spanky is a phony brony.
User avatar
5 Posts
 x 0

Post 15 Aug 2013, 21:41

Thanks, that get rid of the dot.
For the spacing, is there anything i can do ?
Some user were asking the same exact problem in bugs section on CC forum.
Some jargon i didn't understand, but two statement stand out though. (IDK what it means).
Let me quote that for you:
It looks like the tweaked FixedWidthFontRenderer (still used?) doesn't share your appreciation for Sphax textures anyway, if I'm not mistaken it also calculated the font-metrics (size and layout of characters) using some pretty 'delightful' margin detection. I'm going out on a limb here, and saying the renderer isn't producing the visibly correct metric data - and in fact, I don't think it actually ever has with custom fonts but I've not (or can't remember) trying them.

The only thing you can do is disable the custom font; computers aren't the same without the default font - and that font doesn't break the renderer.
Well, I can't say for sure, but it's highly unlikely that we will add support for the texture packs, as it's already available to implement proper support for CC compatibility from the texture pack owners.
So is this a dead end ?
I will try to ask them to implement separate font, but that's very unlikely being implemented like they saying T_T
User avatar
BDcraft Web Admin
5467 Posts
 x 129

Post 15 Aug 2013, 22:14

Actually looking at the issue properly myself now, no, there's no way to fix the spacing as it's apparent with the default font too.

Basically what ComputerCraft is trying to achieve is that every letter is the same width being that of the underscore _ . Obviously in PureBD this is just much much more apparent than with default.

I'm not entirely sure what the person on the CC forum is saying about compatibility. Maybe he's just suggesting it's a bad font? :P I dunno.
If you like a post give it a diamond! :arrow_heading_up:
User avatar
5 Posts
 x 0

Post 16 Aug 2013, 04:30

There are way to fix this, but the steps were tedious.

1a. Launch Minecraft with default theme.
1b. If you launch the game with HD, change the pack to default, exit minecraft, go to step 1a.
2. Load the world
3. Load resource pack

If we've done playing, revert back to default pack so the next time we launch the game,
We didn't have to :
1. change pack to default
2. exit the game
3. relaunch the game
4. load the world
5. change pack to HD

As you can see it's really tedious :(
However,..some question remain.

How come the spacing bug were "gone" if we use default pack, and after loading we simply change the pack to HD, CC will render the font correctly ?

I'm still waiting for CC moderator response, a user were asking the similar question as i am in CC forum.
I will report here if there's any progress.
Locked