Tutorial: Giving Minecraft more RAM

You need some technical assistance with our resourcepacks or website or general help with Minecraft, including mods.
Post Reply
User avatar
4 Posts
 x 0

Post 02 Aug 2013, 02:28

Here's a good tip I noticed. For me, under the JVM thing it says:


-Xmx1G

When I tried simply changing that to "-Xmx6G" it crashed me every time, with and without mods. However, when I typed in...

-Xmx1G -Xmx6G

It worked perfectly, and I now have a whopping 5461 MB of RAM!

This may work just for me, but it worked, and it may work for you.




Note: my computer itself has 12 GB of RAM.
"FOR HYRULE!"
User avatar
BDcraft Web Admin
5409 Posts
 x 126

Post 02 Aug 2013, 20:19

Cyblocker wrote:-Xmx1G -Xmx6G
Interesting. Maybe the Java Runtime Control Panel requires the -Xms when you set a high -Xmx?

You may want to try changing the -Xmx1G to be -Xms1G.

-Xms means "use at least this much RAM".

Then again if your way works... just seems a bit shady :P
If you like a post give it a diamond! :arrow_heading_up:
User avatar
4 Posts
 x 0

Post 03 Aug 2013, 00:39

I had dedicated half my ram to java, which was 16 gb, but i read somewhere it makes the server smoother, and I am usually 90% of the time host when playing minecraft, and it helped alot and my friends quit complaining about lagg
User avatar
4 Posts
 x 0

Post 03 Aug 2013, 15:48

Alright. I swapped it to "-Xms6G" and it's working as usual. Thanks!
"FOR HYRULE!"
User avatar
2 Posts
 x 0

Post 05 Dec 2013, 05:29

i'm on my grandma's old computer that has 2048 RAM, what is the code to type in that would put the max into minecraft for me, i allocated a ton on my laptop using the magic laucnher, but have no idea on the new one, all i need is the code so i can type that in and get going! :D
User avatar
BDcraft Web Admin
5409 Posts
 x 126

Post 05 Dec 2013, 08:19

There's little point in forcing any more RAM usage on a computer that only has 2GB of RAM.

You might be able to push -Xmx1536M (1.5GB).
If you like a post give it a diamond! :arrow_heading_up:
User avatar
2 Posts
 x 0

Post 06 Dec 2013, 00:13

thanks, ill go see if it works
Edit: it did not work, but thanks anyways :D
User avatar
8 Posts
 x 0

Post 14 Jun 2014, 22:43

What about on a voids wrath launcher? i use the vanilla 1.6.4 part and add custom modpacks...tthis has no obvious way of doing it.
User avatar
BDcraft Web Admin
5409 Posts
 x 126

Post 14 Jun 2014, 23:03

You go in Options, uncheck "Let java decide optimal values" and set the max RAM limit.

I'll add the VoidLauncher to the OP. Added.
If you like a post give it a diamond! :arrow_heading_up:
User avatar
8 Posts
 x 0

Post 14 Jun 2014, 23:30

I own a 2 gig computer, and for some reason it either crashes, or when I get it loaded, the textures appear as white squares. i currently have about 15 avalable. I am playing with mods, and it just doesn't want to work for me.
Post Reply